В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
konstontinopols
konstontinopols
09.02.2020 12:15 •  Информатика

Написать программу на паскале которая печатает первую и последнюю цифру 4-х значного числа, сравнивает их и печатает какое из этих двух цифр больше

Показать ответ
Ответ:
Mihael13
Mihael13
07.10.2020 20:01
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
var a:=ReadInteger('Введите число').ToString();
var (d1,d4):=(a[1].ToDigit(),a[4].ToDigit());
writeln('первая: ',d1,'; четвертая: ',d4);
if d1>d4 then write ('больше ',d1) else if d1<d4 then write('больше ',d4) else
write('цифры равны: ',d1);
end.
0,0(0 оценок)
Ответ:
Ороохзшрорр
Ороохзшрорр
07.10.2020 20:01
Var
x:integer;
begin
Read(x);
Writeln(x div 1000, ' ', x mod 10);
if x div 1000 > x mod 10 then Writeln(x div 1000, ' - больше');
if x div 1000 < x mod 10 then Writeln(x mod 10, ' - больше');
if x div 1000 = x mod 10 then Writeln('Они равны');
end.

Пример:
1234
1 4
4 - больше
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота