В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Написать программу на Паскале,используя цикл с постусловием (Repeat-until) для решения задачи. Вычислить сумму всех двухзначных чисел. S=10+2+3+...+99. Сделайте так чтобы мой Паскаль, принял вашу программу

Показать ответ
Ответ:
McVano
McVano
25.03.2020 06:38
#include <iostream>
#include <algorithm>

using namespace std;

void sort(int a[], int n) { 
for (int i = 0; i < n; i++) {   
   int j = i;   
   while (j > 0 && a[j - 1] > a[j]) {       
         if (a[j - 1] > a[j]) {         
           swap(a[j - 1], a[j]);       
         }     
        j--;   
      } 
    }
}

int main() {
int n;
cin >> n;
int count = 0;
int *a = new int[n];
for (int i = 0; i < n; i++) {
 cin >> a[i];
}
sort(a, n);
for (int i = 0; i < n; i++) {
 if (a[i] != a[i + 1]) {
  count++;
 }
 cout << a[i] << " ";
}
cout << endl << count;
delete[]a;
}
0,0(0 оценок)
Ответ:
Mишутка9887
Mишутка9887
06.11.2021 22:04
Найти соответствующую информацию в сети Интернет и ответить письменно на вопросы:
Какие объекты или процессы изучают следующие науки: география, геология, химия, астрономия? Можно ли создать абсолютно точные компьютерные модели этих объектов и процессов? Предположим, вам нужно создать компьютерную модель химической реакции. Какие свойства объектов и процессов были бы существенными для вашей модели?
Предположим, вам нужно создать компьютерную модель, демонстрирующую связь между изменением численности населения на некоторой территории и изменением площади лесов на этой территории. Какой вид компьютерной модели вы выбрали бы? Какие объекты и процессы моделировала бы ваша модель? Какие свойства этих объектов и процессов были бы существенными для процесса моделирования?
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота