В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
DikONd
DikONd
17.11.2022 16:25 •  Информатика

Написать программу на Паскале для решения следующей задачи: с клавиатуры вводятся 2 числа. Определить, являются ли они четными и кратными 6, а также, какое из чисел больше, его (большее число) заменить числом 100.

Показать ответ
Ответ:
NAREK097
NAREK097
11.03.2020 00:48

Лента в Microsoft Word позволяет максимально быстро получить доступ к наиболее часто используемым командам. Лента содержит огромное количество команд, которые разбиты по смысловым группам. В этом уроке Вы узнаете, из каких вкладок состоит Лента, а также научитесь скрывать ее, чтобы увеличить рабочую область Word на экране монитора.

Если Вы ранее пользовались Word 2010 или 2007, тогда Word 2013 покажется Вам знакомым. В нем используются все те же Лента и Панель быстрого доступа, где можно найти команды для наиболее часто используемых задач, а также представление Backstage.

Объяснение:

0,0(0 оценок)
Ответ:
крис897
крис897
28.08.2022 01:34
//Pascal ABC.NET v3.0 сборка 1111

var
 i,a,b:integer;
 ar:array[1..10] of integer;

 procedure oddDec(var a,b:integer);  //подпрограмме переданы аргументы a и b
//процедура для вычитания в нечётном элементе
begin;
a:=a-b;
end;

procedure NotoddInc(var a,b:integer); //подпрограмме переданы аргументы a и b
//процедура для сложения в чётном элементе
begin;
a:=a+b;
end;

begin
randomize;
readln(a); //ввод a
readln(b); //ввод b
writeln('Array:');
for i:=1 to 10 do //весь массив
 begin;
  ar[i]:=random(-20,80); //случайные числа от -20 до 80 включительно
  write(ar[i]:4); //вывод
  if odd(i) then oddDec(ar[i],b) else NotoddInc(ar[i],a);
  {если нечётное, то первая процедура, иначе вторая. Обращаю внимания на то, что элементы меняются сразу после вывода}
 end;
writeln;
writeln('Final array:'); //вывод получившегося массива
for i:=1 to 10 do
write(ar[i]:4);
end.

Пример ввода:
20
10
Пример вывода:
Array:
  10  16   0  60  23   4  22 -20   4  55
Final array:
   0  36 -10  80  13  24  12   0  -6  75  
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота