В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
2312YQw
2312YQw
08.08.2021 07:45 •  Информатика

Написать программу на паскале дается список студентов с личными данными и данными о днях рождения. требуется вывести номера тех студентов, которые родились летом. летними считать следующие месяцы: июнь, июль, август. месяцы нумеруются с единицы. формат входных данных в первой строке входного файла находится число n(1≤n≤50). в следующих n строках описываются данные о студентах, по одной строке на человека. каждая строка содержит через пробел фамилию, имя, отчество, число, месяц и год рождения. имя, фамилия и отчество представляют из себя последовательность символов или латинского алфавитов, и не содержат каких-либо пробельных символов. формат выходных данных в выходной файл выведите k - количество студентов, родившихся летом. после этого выведите k чисел - номера студентов, родившихся летом. студенты нумеруются с единицы в том порядке, в котором они перечислены во входном файле. номера выводите в порядке возрастания. примеры: вход 2 иванов иван иванович 10 2 2007 петров петр петрович 10 6 2007 выход 1 2

Показать ответ
Ответ:
Владислава1626
Владислава1626
03.10.2020 06:38
//Pascal ABC.NET v3.0 сборка 1111

Var 
 ars:array[1..50] of string;
 ark:array[1..50] of integer;
 s:string;
 i,n,k,j:integer;
begin
 readln(n);
 k:=0;
 for i:=1 to n do
  begin;
   readln(ars[i]);
    for j:=1 to 4 do
     delete(ars[i],1,pos(' ',ars[i]));
    s:=ars[i];
    if (s[1]='6') or (s[1]='7') or (s[1]='8') then
     begin;
      inc(k);
      ark[k]:=i;
     end;
  end;
writeln(k);
for i:=1 to k do
writeln(ark[i]);
end.

Пример ввода:
2
Петров Петр Петрович 10 6 2007
Иванов Иван Иванович 10 2 2007
Пример вывода:
1
1
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота