Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
geklaoycd9v
30.11.2022 21:47 •
Информатика
Написать программу на pascal вычислить сумму квадратов вводимых чисел. числа вводятся, пока не будет нажат ноль.
Показать ответ
Ответ:
66vdv1
07.10.2020 17:28
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
var a:=ReadSeqIntegerWhile(x->x<>0).ToArray();
a.Transform(x->x*x);
write(a.Sum());
end.
0,0
(0 оценок)
Ответ:
гол38
07.10.2020 17:28
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('Сумма квадратов: ',ReadSeqIntegerWhile(t->t<>0).Select(t->t*t).Sum)
end.
Пример
16 -23 18 24 5 -12 7 11 9 5 2 0
Сумма квадратов: 2134
0,0
(0 оценок)
Популярные вопросы: Информатика
7klassnik1
27.03.2021 22:51
Пусть видеопамять компьютера имеет 1024 кбайт. размер графической сетки 640х480. сколько страниц экрана одновременно разместится в видеопамяти при палитре 256 цветов?...
mishajordan213
14.03.2021 23:49
Кто шарит в пайтоне с задачей очень нужноо...
Masha0501
25.05.2023 11:22
5. Код буквы в кодировочной таблице на рисунке 2 образуется из номера строки и номера столбца. Например, буква и кодируетсячислом 25. Потому что буква и находится на...
yuliasitnikova
19.02.2020 10:35
Перевести число 11000 из двоичной сс в десятиричную...
kimiKatocom
19.11.2020 08:25
Как называется внутреннее устройство компьютера для обработки информации?...
Spokeup
24.05.2023 04:40
Сөйлемдерді толықтыр...
svetysa95
06.05.2021 17:57
Твір на тему похід на віртуальну екскурсію в україні...
Keklo12
10.03.2023 13:40
Просклоняй словосочетания: Шестьсот детей, семьсот людей....
ladyplahtiy
26.02.2021 04:46
Найти число атомов в 125 см3 железа и их концентрацию....
s0nnka
24.01.2021 19:44
Поставьте прилагательные в нужную степень: 1. My coffee is ( hot )than yours 2. The Cheetah is the( fast) among the animals 3. A geography teacher is ( strict ) than...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
//Версия 3.3, сборка 1611
begin
var a:=ReadSeqIntegerWhile(x->x<>0).ToArray();
a.Transform(x->x*x);
write(a.Sum());
end.
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('Сумма квадратов: ',ReadSeqIntegerWhile(t->t<>0).Select(t->t*t).Sum)
end.
Пример
16 -23 18 24 5 -12 7 11 9 5 2 0
Сумма квадратов: 2134