В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
яна7933
яна7933
31.03.2022 03:25 •  Информатика

Написать программу на pascal: Рассматривается треугольник. На вход алгоритму подаются два числа – значения углов в градусах, прилежащих к одной из сторон треугольника. Считается, что любой треугольник можно охарактеризовать одновременно двумя по виду его углов и виду его сторон. По виду углов треугольник может быть остроугольным, тупоугольным и прямоугольным. По виду сторон треугольник может быть разносторонним (все стороны разные), равнобедренным (только две стороны одинаковые) и равносторонним (все стороны равные). Алгоритм должен определить, к какому виду сторон и углов относится треугольник, и вывести соответствующее сообщения.

Показать ответ
Ответ:
13semiy
13semiy
11.06.2021 04:19

5б:

x = input("введите число: ")

y = ""

for i in range(len(x)):

   y += (x[-i])

if x==y:

   print ("Перевертыш")

else:

   print ("Нет")

6:

x1 = int(input("x1: "))

y1 = int(input("y1: "))

x2 = int(input("x2: "))

y2 = int(input("y2: "))

R1 = (x1**2 + y2**2)**(0.5)

R2 = (x2**2 + y2**2)**(0.5)

if R1 > R2:

   print ("2 ближе")

elif R2>R1:

   print ("1 ближе")

else:

   print("одинаково")

7:

a = int(input("1 сторона: "))

b = int(input("2 сторона: "))

c = int(input("3 сторона: "))

if (a>=b+c) or (b>=a+c) or (c>=b+a):

   print("не существует")

elif a==b and b==c:

   print ("Равносторонний")

elif a==b or b==c or a==c:

   print ("Равнобедренный")

else:

   print("Существует")

Объяснение:

Там все понятно

0,0(0 оценок)
Ответ:
Niktommy
Niktommy
05.08.2020 07:48

1)

using System;

class Program {

   static void Main() {

       int num = 16;

       bool isPow2 = true;

       

       while (num > 1){

           if (num % 2 == 0){

               num /= 2;

           } else {

               isPow2 = false;

               break;

           }

       }

       

       if (isPow2)

           Console.WriteLine("Является");

       else

           Console.WriteLine("Не является");

   }

}

2)

using System;

class Program {

   static Random rnd = new Random();

   

   static void Main() {

       int min = 1;

       int max = 100;

       int numOfAttempts = 8;

       int x = rnd.Next(min, max);

       bool isWin = false;

       

       Console.WriteLine("Игра \"Больше-Меньше\"");

       Console.Write("Задайте число попыток: ");

       numOfAttempts = Convert.ToInt32(Console.ReadLine());

       Console.WriteLine("Отгадайте число от {0} до {1}", min, max);

       Console.WriteLine("Попытки: {0}\n", numOfAttempts);

       int input;

       do {

           Console.Write("Введите число: ");

           input = Convert.ToInt32(Console.ReadLine());

           numOfAttempts--;

           if (input > x)

               Console.WriteLine("x < {0}   [попытки: {1}]", input, numOfAttempts);

           if (input < x)

               Console.WriteLine("x > {0}   [попытки: {1}]", input, numOfAttempts);

           if (input == x){

               isWin = true;

               break;

           }

       } while (numOfAttempts > 0);

       

       if (isWin){

           Console.WriteLine("\nПобеда!");

       } else {

           Console.WriteLine("\nПроигрыш! Загаданное число: {0}", x);

       }

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота