В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Анечка1611
Анечка1611
12.01.2023 06:56 •  Информатика

Написать программу на pascal: дан массив целых чисел. удалить первый чётный элемент входного списка, не кратный 6. дополнительные списки, стандартные функции и срезы не использовать.

Показать ответ
Ответ:
LizaIlina1
LizaIlina1
27.06.2020 11:42

begin

for var n: Integer := 1 to 5 do

writeln('в ', n, ' день количество заболевших составляет ', power(4,n-1), ' чел.')

end.

Посчитал тут на 15 дней:

в 1 день количество заболевших составляет 1 чел.

в 2 день количество заболевших составляет 4 чел.

в 3 день количество заболевших составляет 16 чел.

в 4 день количество заболевших составляет 64 чел.

в 5 день количество заболевших составляет 256 чел.

в 6 день количество заболевших составляет 1024 чел.

в 7 день количество заболевших составляет 4096 чел.

в 8 день количество заболевших составляет 16384 чел.

в 9 день количество заболевших составляет 65536 чел.

в 10 день количество заболевших составляет 262144 чел.

в 11 день количество заболевших составляет 1048576 чел.

в 12 день количество заболевших составляет 4194304 чел.

в 13 день количество заболевших составляет 16777216 чел.

в 14 день количество заболевших составляет 67108864 чел.

в 15 день количество заболевших составляет 268435456 чел.

Так что, на 15-ый день грипповать будет уже больше, чем у нас в стране населения. Как говорится, думайте сами, решайте сами...

0,0(0 оценок)
Ответ:
Ехепхеп
Ехепхеп
06.06.2021 19:29

Відповідь:

#include <iostream>

#include<string>

#include<cmath>

int main() {

setlocale(0,"");

double suma;

int misyac;

std::string s;

while(1){

 

try{

std::cout<<"Введіть суму вкладу:\n";

std::cin>>s;

suma = std::stod(s);

if(suma<=0) throw 4;/*Помилка від'ємного числа*/

break;

}

catch(int/*Ловимо помилку від'ємного числа'*/){

std::cout<<"Недопустиме значення, повторіть введення.\n";}

catch(.../*Ловимо будь-що*/){

 std::cout<<"Невірний ввід, повторіть будь ласка.\n";

}}

while(1){

 

try{

std::cout<<"Введіть кількість місяців:\n";

std::cin>>s;

misyac = stoi(s);

if(misyac<0) throw 4;

break;

}

catch(int/*Ловимо помилку від'ємного числа*/){

std::cout<<"Недопустиме значення, повторіть введення.\n";}

catch(.../*Ловимо будь-що*/){

 std::cout<<"Невірний ввід, повторіть будь ласка.\n";

}}

std::cout<<"За "<<misyac<<" місяців зі сумою вкладу розміром "<<

suma<<" гривень при депозиті у 10% за місяць у вас буде "<<suma*pow(1.1,misyac);

 

 

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота