написать программу на Java !
Какова N-я перестановка цифр 0 1 2 3 4 5 6 7 8 9, если предположить, что их генерировали в лексикографическом порядке?
На вход подается N
Выход 10 цифр без пробелов – перестановка под номером n
Входные данные
1
Выходные данные
0123456798
Входные данные 2
2
Выходные данные 2
0123456879
устройстве (ПЗУ ) компьютера IBM/PC, определяют эффективность
работы персонального компьютера в целом. В данной главе мы
излагаем самые общие сведения, касающиеся ПЗУ. Мы рассмотрим
назначение ПЗУ, специфику анализа и декодирования
(реконструкции) хранящейся там информации и, наконец, сравним
между собой две первые версии ПЗУ компьютера IBM/PC. Все эти
материалы являются базой для последующих пяти глав, в которых
функциональные возможности IBM/PC рассматриваются более
детально.
Здесь важно иметь в виду три аспекта. Все о чем пойдет
речь в данной главе в полной мере относится только к IBM/PC
и, вообще говоря, не распространяется на все семейство
компьютеров, работающих под управлением MS-DOS. Для остальных
компьютеров семейства PC эти сведения следует рассматривать
применительно к конкретному компьютеру (поскольку каждой
модели присущи свои особенности). Тем не менее, имеются все
основания считать, что прерывания или вызовы функции
обслуживания для большинства компьютеров совпадают. Поэтому,
несмотря на возможное изменение адресов программ
обслуживания, находящихся в ПЗУ компьютера той или иной
модели материалы настоящей и последующих пяти глав сохраняют
свою актуальность.
using namespace std;
int main(){
int max,k,n,nod,p;
int ar[1000];
cin>>n;
for(int i=0;i<n;i++){
cin>>ar[i];
}
max=ar[0];
for(int i=1;i<n;i++){
if(ar[i]>max){
max=ar[i];
k=1;
nod=1;}
}
while(k!=max){
k++;
p=0;
for(int i=0;i<n;i++){
if(ar[i]%k==0){
p++;}}
if(p==n){
nod=k;}
}
cout<<"NOD="<<nod;
cin.get();
cin.get();
return 0;
}