В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
милаш06
милаш06
04.01.2020 15:48 •  Информатика

написать программу на delfi Защита программы с использованием алгоритма "мутации"

Показать ответ
Ответ:
шогвшвгвшр
шогвшвгвшр
05.04.2022 02:01

Смотри картинку

Объяснение:

Крестик - начало слова, стрелка - конец.

Абак - счётные доски для вычислений в Древней Греции, Древнем Риме, Древнем Китае и т.д.

Арифмометр - настольная или портативная механическая вычислительная машина.

Перфокарта - носитель информации. Тонкий картон с отверстиями или без них в определённых местах.

Транзистор - полупроводниковое устройство, которое используется для усиления, генерации и преобразования электрических сигналов. Транзисторы заменили вакуумные лампы в большинстве электронных устройств, свершив революцию в создании интегральных схем и компьютеров.

ЭНИАК – первая электронная вычислительная машина.

Бэббидж Чарлз - изобретатель первой аналитической вычислительной машины.

Лавлейс Ада - написала первые программы для аналитической вычислительной машины Беббиджа.

Лейбниц - предложил двоичную систему счисления, автор первой механической счётной машины производившей сложение, вычитание, умножение и деление чисел.

Возняк Стив - один из основателей компании Apple. Разработал первый массовый домашний компьютер и первый массовый персональный компьютер.

Холлерит Герман - создатель электрической статистической табулирующей системы (оборудования для работы с перфокартами).

Непер Джон - изобретатель логарифмов, для их вычисления он предложил устройство под названием «палочки Непера».

Шиккард Вильгельм - придумал «Считающие часы», первый арифмометр, умевший выполнять четыре арифметических действия.

Паскаль Блез - автор первой механической счётной машины, выполнявшей сложение и вычитание чисел. (Паскаль - один из наиболее известных языков программирования.)

Лебедева Сергей - под его руководством была создана МЭСМ (малая электронная счётная машина).


Сканворд на темуИВТ Нужно найти 14 слов
0,0(0 оценок)
Ответ:
gulya19860630
gulya19860630
28.05.2020 22:49

import java.util.Scanner;

public class Authenticator {

public static void main(String[] args) {

 String login;

 String password;

 Scanner scan = new Scanner(System.in);

 

 System.out.println("login:");

 login = scan.next();

 System.out.println("password:");

 password = scan.next();

 

 if(login.equals("user") && password.equals("qwerty")){

  System.out.println("Authentication completed");

 }else{

  System.out.println("Invalid login or password");

 }

 

 scan.close();

 

}

}

Объяснение:

Краткий алгоритм этой программы:Импортируем класс Scanner(для ввода текста);В методе main создаем две переменные типа String и одну типа Scanner;Вводим значения при а;Если логин и пароль верны,то выводим Authentication completed. Иначе выводим Invalid login or password;Закрываем Scanner;
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота