В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

написать программу на C# Постройте таблицу значений функции y=f(x) для хÎ[a, b] с шагом h. Если в некоторой точке x функция не определена, то выведите на экран сообщение об этом.


написать программу на C# Постройте таблицу значений функции y=f(x) для хÎ[a, b] с шагом h. Если в не

Показать ответ
Ответ:
Waz4
Waz4
10.06.2022 04:44
Const   n = 50; // количество чиселvar   k: array [1..n] of integer;   i, j, n1, n2, minr, a, b: integer; begin   writeln(n, ' ', ': d');   a : = random(1000);   b : = random(1000);   minr : = 10000;   for i : = 1 to n do       k[i] : = a + random(b);   for i : = 1 to n do       for j : = 1 to n do           if ((abs(k[i] - k[j])) < minr) and (k[i] < > k[j]) then           begin               minr : = abs(k[i] - k[j]);               n1 : = i;               n2 : = j;           end;   writeln(n1, ' ', n2); end.
0,0(0 оценок)
Ответ:
10071927
10071927
26.12.2021 11:56

#include <iostream>

#include <vector>

#include <algorithm>

#include <ctime>

using namespace std;

int main()

{

srand(time(NULL));

int n, max = 0, index1, min = 0, index2;

cin >> n;

cout << "RANDOM ARRAY:\n";

vector <int> a(n);

for (int i = 0; i < n; i++)

{

 a[i] = rand() % 101;

 if (a[i] > max) {

  max = a[i]; index1 = i;

 }

 if (a[i] < min || min == 0) {

  min = a[i]; index2 = i;

 }

 cout << a[i] << " ";

}

cout << "\nARRAY:\n";

if (index2 < index1)

{

 int x;

 x = index2;

 index2 = index1;

 index1 = x;

}

reverse(a.begin() + index1, a.begin() + index2);

for (int i = 0; i < n; i++)

{

 cout << a[i] << " ";

}

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота