В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
макс3092
макс3092
20.03.2023 15:28 •  Информатика

Написать программу на c# написать программу, удаляющую из записи числа все чётные цифры.

Показать ответ
Ответ:
soloveyandrey3
soloveyandrey3
02.10.2020 01:30
Static class Program
{
    public static IEnumerable<uint> Digits(this uint X, bool Reverse = true)
    {
        do { yield return X % 10; } while ((X /= 10) != 0);
    }

    static uint ToUnsignedInt32(this IEnumerable<uint> Digits)
    {
        return Digits.Reverse().Aggregate((a, d) => a * 10 + d);
    }

    static void Main()
    {
        Console.WriteLine(
            uint.Parse(Console.ReadLine())
                .Digits()
                .Where(d => d % 2 == 1)
                .ToUnsignedInt32());
                
        Console.ReadKey();
    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота