В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Daliloshka
Daliloshka
18.08.2020 06:40 •  Информатика

написать программу на C++! Написать класс для эффективной работы со строками, позволяющий
форматировать и сравнивать строки, хранить в строках числовые значения и
извлекать их. Для этого необходимо реализовать:
 Перегруженные операторы присваивания и конкатенации;
 Операции сравнения и приведения типов;
 Преобразование в число любого типа;
 Форматный вывод строки.
Написать программу, демонстрирующую работу с этим классом. Программа
должна содержать меню, позволяющее осуществить проверку всех методов
класса.

Показать ответ
Ответ:
элизабет35
элизабет35
26.04.2020 23:22

#рщыщрырыщчрщычрщычр, ыр, щрыщ, рыщ, рщыр, шыр, шыр, шыр, шыр, 8ры7,ры7,ыр7,ыпшы,пш,ыпш,ыпш,ышп,ырш,ршы,рпгкзк1спгзк1гзк1псгщк1сг931ш9рс1у79ср379чргу9в65дфу5щыкз6ык6з6н7ав2гзп3сгзпус1шрзусгизшр3срз3шзр3чзгручрзрчгзуршзчурсш93срш9у1арг931ра39ра93шра3ш9ар9ш3ср9шсрш931ср39шрмш9к1мрг1к993сп9гк1ср1кгрсг91ксрк9г1рм9гк1мп1к9гпм9г1кпм3г9пмг9упм9г3ппм79п3пм793мпгу9у92хра3маоз33зовмоз2мвомз22гвп2г8вм8гвк18гс3н81сузц6кжй3563ц63фы63х6ь4ггь462щ6юд зкплз2зоус11рчш9у1рсш01урс801ур7914рс803ос083ар8831ра91ос831оа83ра835ддывжегйыну6щ 9в58внвнд6удк6

0,0(0 оценок)
Ответ:
kirillmich16
kirillmich16
31.07.2020 21:17

string a;

string b;

int count = 0;

int count2 = 0;

bool g = false;

bool g2 = false;

Console.WriteLine("Введите первую строку");

a = Convert.ToString(Console.ReadLine());

Console.WriteLine("Введите первую строку");

b = Convert.ToString(Console.ReadLine());

Console.WriteLine("Введите первый символ");

Макрой avatar

char first_symbol = Convert.ToChar(Console.ReadLine());

Console.WriteLine("Введите последний символ");

char second_symbol = Convert.ToChar(Console.ReadLine());

char[] separ = { ' ' };

string[] a1 = a.Split(separ);

string[] b1 = b.Split(separ);

Макрой avatar

for (int i = 0; i < a1.Length; i++)

if (a1[i].IndexOf(first_symbol) == 0 && a1[i].IndexOf(second_symbol) == a1[i].Length - 1)

{

Console.Write(a1[i]+";"); count++; g= true;

}

if (g)

{

Console.WriteLine(" В этой строке :" + count + " слов(о)");

}

Console.WriteLine();

Макрой avatar

for (int i = 0; i < b1.Length; i++)

if (b1[i].IndexOf(first_symbol) == 0 && b1[i].IndexOf(second_symbol) == b1[i].Length - 1)

{

Console.Write(b1[i]+";"); count2++; g2 = true;

}

if (g2)

{

Console.WriteLine(" В этой строке :" + count2 + " слов(о)");

}

Console.ReadLine();

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота