В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
sofka123890
sofka123890
27.01.2021 14:21 •  Информатика

Написать программу на c# известны данные о стоимости каждой из 15-ти моделей автомобилей и об их типе (легковой или грузовой). найти среднюю стоимость грузовых автомобилей.

Показать ответ
Ответ:
Nikito23
Nikito23
30.04.2022 09:08

#include <iostream>

using namespace std;

int main() {

const int M = 3;

const int N = 4;

int matrix [M][N] = {};

int k,s=0,pr=1;

cout << "Введите k:" << endl;

cin >> k;

for (int i = 0; i < M; i++) { //забиваем матрицу случайными числами

 for (int j = 0; j < N; j++) {

  matrix[i][j] = rand() % 10;

 }

}

for (int i = 0; i < M; i++) { //находим сумму и произведение

 s += matrix[i][k-1];

 pr *= matrix[i][k-1];

}

for (int i = 0; i < M; i++) { //выводим матрицу на экран

 for (int j = 0; j < N; j++) {

  cout << matrix[i][j] << " ";

 }

 cout << endl;

}

cout << s << endl << pr; //выводим на экран сумму и произведение элементов

return 0;

}

0,0(0 оценок)
Ответ:
kobita
kobita
19.02.2022 20:06

Ре­ше­ние.

Ко­ли­че­ство путей до го­ро­да Х = ко­ли­че­ство путей до­брать­ся в любой из тех го­ро­дов, из ко­то­рых есть до­ро­га в Х.

При этом если путь дол­жен не про­хо­дить через какой-то город, нужно про­сто не учи­ты­вать этот город при подсчёте сумм. А если город на­о­бо­рот обя­за­тель­но дол­жен ле­жать на пути, тогда для го­ро­дов, в ко­то­рые из нуж­но­го го­ро­да идут до­ро­ги, в сум­мах нужно брать толь­ко этот город.

С по­мо­щью этого на­блю­де­ния по­счи­та­ем по­сле­до­ва­тель­но ко­ли­че­ство путей до каж­до­го из го­ро­дов:

А = 1

Б = А = 1

Д = А = 1

Г = А + Д = 1 + 1 = 2

В = А + Б + Г = 4

Е = В = 4

Ж = В + Е = 4 + 4 = 8

З = 0 (по­сколь­ку в З не ведёт ни одна до­ро­га из В)

И = Е + Ж = 4 + 8 = 12.

 

При­ве­дем дру­гое ре­ше­ние.

Ко­ли­че­ство путей из го­ро­да А в город И, про­хо­дя­щих через город В, равно про­из­ве­де­нию ко­ли­че­ства путей из го­ро­да А в город В и ко­ли­че­ства путей из го­ро­да В в город И.

Най­дем ко­ли­че­ство путей из го­ро­да А в город В:

А = 1

Б = А = 1

Д = А = 1

Г = А + Д = 1 + 1 = 2

В = А + Б + Г = 4.

Най­дем ко­ли­че­ство путей из го­ро­да В в город И (при этом В - ис­ход­ный пункт):

В = 1

Е = В = 1

Ж = В + Е = 1 + 1 = 2

И = Е + Ж = 1 + 2 = 3.

Тогда ко­ли­че­ство путей из го­ро­да А в город И, про­хо­дя­щих через город В, равно 4 · 3 = 12.

 

При­ме­ча­ние. Не­об­хо­ди­мо найти ко­ли­че­ство раз­лич­ных путей из го­ро­да А в город И, про­хо­дя­щих через город В.

 

ответ: 12.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота