В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
KarinochkaShiну
KarinochkaShiну
18.02.2021 22:20 •  Информатика

Написать программу на C++. Исходные данные 0,15. Точность вычисления 10^-3


Написать программу на C++. Исходные данные 0,15. Точность вычисления 10^-3

Показать ответ
Ответ:
Артёмка12097
Артёмка12097
13.02.2020 18:57

#include <iostream>

typedef long long   ll;

using namespace std;

bool ll_is_valid(ll t, ll N, ll x, ll y)

{

return  t / x + (t - x) / y >= N;

}

ll f(ll N, ll x, ll y)

{

   ll R = 1;

   while (!ll_is_valid(R,N,x,y)) R *= 2;

ll L = R / 2;

while(R - L > 1)

{

 ll M   =   (L + R) / 2;

 

 if (!ll_is_valid(M,N,x,y)) {L = M;}

 else {R = M;}

}

return  R;

}

int  main()

{

ll N,x,y;

cin >> N >> x >> y;

if(x > y) swap( x, y );  

cout << f(N, x, y) <<  std::endl;

}

0,0(0 оценок)
Ответ:
vikailen
vikailen
19.09.2022 10:32
Вопрос с подвохом, пропускная меряется не от возможной передачи на стороне провайдера или пользователя, а от версии протокола 2СH (2 цэ-аш). Рассмотрим 2 последние версии. Протокол 2015 года поддерживал пропускную вплоть до 20 MB/WEBM. Стандарт нового протокола поразили многих экспертов, скорость была снижена вдвое. Но сделано это было в связи с отказом многих производителей сетевого оборудования устанавливать расширяющие микросхемы PassCODE для поддержки тех самых 20 MB/WEBM. Может в будущем, с большим распространением PassCODE пропускную поднимут, но пока приходится с этими ограничениями смирится и перекодировать WEBM что несомненно, приведет к ухудшению их качества. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота