Написать программу на c++
цикл со счетчиком
с клавиатуры вводится n целых чисел a1, a2, …,an.
в процессе ввода чисел выводить на экран следующие суммы: a1+a2, a2+a3, …, an-1+an.
цикл с предусловием
вычислите сумму всех чисел фибоначчи, которые не превосходят заданного натурального числа м.
числа фибоначчи определяются по формулам: f0=f1=1; fi=fi-1+fi-2.
цикл с постусловием
вычислите частичную сумму ряда
s=1 -x^2/2! + x^4/4! - x^6/6! + … .
вычисления прекратите, когда модуль очередного слагаемого станет меньше 0,001. значение x вводится с клавиатуры. проверьте, насколько сумма приблизилась к значению cos(x), x измеряется в радианах.
const
a=-6; b=6; h=1;
begin
for var x:=a to b do Writeln('x=',x:2,', y=',ln(sqr(x)-9)/x)
end.
Результат выполнения программы:
x=-6, y=-0.549306144334055
x=-5, y=-0.554517744447956
x=-4, y=-0.486477537263828
x=-3, y=бесконечность
x=-2, y=NaN
x=-1, y=NaN
x= 0, y=NaN
x= 1, y=NaN
x= 2, y=NaN
x= 3, y=-бесконечность
x= 4, y=0.486477537263828
x= 5, y=0.554517744447956
x= 6, y=0.549306144334055
Примечание: NaN система выдает, если не может выполнить какое-то действие. В данном случае под знаком логарифма оказывается неположительное число.
Пусть количество пикселей в рисунке K, тогда объем памяти, занимаемой одним рисунком = (K*3)/1024 + 128 Кбайт.
X = 8*(K*3/1024 + 128)+2.5*1024
2. При использовании палитры из 2^16 цветов для хранения цвета 1 пикселя используется 16 бита = 2 байта.
Объем памяти, занимаемой одним рисунком = (K*2)/1024 + 128 Кбайт.
X = 20*(K*2/1024 + 128)
8*(K*3/1024 + 128)+2.5*1024 = 20*(K*2/1024 + 128)
К = 65536 (количество пикселей в рисунке)
X = 20*(K*2/1024 + 128) = 20*(65536*2/1024 + 128) Кбайт =
20*(128 + 128) Кбайт = 5120 Кбайт = 5120/1024 Мбайт = 5 Мбайт