В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Sasci
Sasci
24.05.2022 23:58 •  Информатика

Написать программу, на ассемблере, которая выводит на экран сумму, разность, произведение, частное введённое с клавиатуры

Показать ответ
Ответ:
zero161
zero161
08.07.2021 19:17

import java.util.Arrays;

import java.util.Scanner;

public class Main {

   public static void main(String[] args) {

       Scanner in = new Scanner(System.in);

       int n = in.nextInt();

       int k = in.nextInt();

       int[] array = new int[n];

       int[] array1 = new int[n];

       for (int i = 0;i < array.length;i++){

           array[i] = in.nextInt();

       }

       for (int i = 0;i < k;i++){

          array1[i] = in.nextInt();

           System.out.println(binarySearch(array,array1[i]));

       }

        }

   static String binarySearch(int[] sortedArray, int key) {

       int index = -1;

       int low = 0;

       int high = sortedArray.length - 1;

       while (low <= high) {

           int mid = (low + high) / 2;

           if (sortedArray[mid] < key) {

               low = mid + 1;

           } else if (sortedArray[mid] > key) {

               high = mid - 1;

           } else if (sortedArray[mid] == key) {

              return "YES";

           }

       }

       return "NO";

   }

}

Объяснение:

0,0(0 оценок)
Ответ:
nuk890
nuk890
19.11.2022 08:38

ответ:Доброго времени суток.

Очень не корректно поставлен вопрос. Что есть Текст? Это текстовый файл, строка, введенная пользователем, еще что-то? Думайте, прежде чем спросить, и, скорее всего, получите нормальный ответ.

Поэтому, поскольку нет конкретики, будем считать текстом строку, введенную пользователем.

Write('Введите текст : ');

ReadLn(S);

В переменной S теперь находится некоторый текст. Начнем с ним работать. Будем считать словом последовательность символов, ограниченных с обеих сторон пробелами. Сначала сделаем копию введенного текста.

S1 := ' ' + S + ' '; {чтобы не потерять первое и последнее слова}

А дальше,  

N := 0; {счетчик слов Мама}

while Pos(' Мама ', S1) > 0 then begin

Delete(S1, Pos(' Мама ', S1)+1, 4);

N := N + 1;  

end;

Поскольку может в тексте быть и "мама", то повторим

while Pos(' мама ', S1) > 0 then begin

Delete(S1, Pos(' мама ', S1)+1, 4);

N := N + 1;  

end;

Вот и все. Осталось вывести результат.

WriteLn('Во ввденном тексте слово "мама" встречается ', N, ' раз');

Удачи!

PS Можно было бы не делать второй проход, если предварительно преобразовать введенный текст к одному регистру, а затем искать подстроку в этом регисте.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота