В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
PANDAnumber
PANDAnumber
21.01.2022 01:35 •  Информатика

Написать программу которвя вычисляет сумму n первых чисел кратных 2

Показать ответ
Ответ:
listikistik
listikistik
12.02.2021 15:37

На будущее, уточняйте на каком языке программирования нужно написать. Так как не указано язык программирования, то я просто напишу алгоритм, а Вы уже сами постараетесь перевести на нужный язык.

int sum; - создаем переменную sum;

int n; - создаем переменную n;

int index = 0; - создаем переменную index, при которой будем считать сколько раз введено число, которое кратное 2;

while(index != 2){ - создаем цикл, который будет спрашивать ввод числа n до тех пор, пока мы не напишем два числа которые будут кратные 2;

cin >> n; - вводим наше n;

if( (n % 2) == 0){ - пишем условия, в котором проверяем, если остаток от деления на 2, равен 0, то мы делаем некоторые вещи, а именно:

sum = sum + n; - в нашу суму добавляем число n;

index = index + 1; - "записываем" в index понятие, что мы нашли уже одно число.

}

cout << sum; - выводим нашу итоговую сумму.

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота