В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Excellent11
Excellent11
17.07.2021 23:42 •  Информатика

Написать программу которая запросит длинны трёх сторон треугольника. проверить возможность его сущ. и в предположенном результате найдёт и выведет на экран площадь один кто !

Показать ответ
Ответ:
GABITOV2018
GABITOV2018
05.10.2020 04:05
Var  
a,b,c{длины сторон}, S{площадь тр.}, p{полупериметр}:double;
begin
writeln('Введите стороны треугольника:');
readln(a,b,c);
     if (a>=b+c) or (b>=a+c) or (c>=a+b) then     
     writeln ('Такого треугольника не существует')     
     else begin   
     p:=(a+b+c)/2;     
     S:=sqrt(p*(p-a)*(p-b)*(p-c)); {вычисляем S тр. по формуле Герона}     
     writeln ('Такой треугольник существует, его S = ', S, 'ед.');     
     end;     
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота