В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Написать программу,которая запрашивает с клавиатуры четырехзначное число и сравнивает в нём первую и последнюю цифры, вторую и третью цифры. если первая цифра равна четвёртой, а третья второй, то выводит на экран "палиндорм", а в противном случае "не палиндорм".

Показать ответ
Ответ:
SuperWalker
SuperWalker
15.09.2020 23:39
Var
  a:integer;
begin
  write('Введите число ');
  readln(a);
  if (a div 1000 = a mod 10) and ((a div 100)mod 10 =(a div 10)mod 10)then
  writeln('Палиндром')
  else writeln('не Палиндром');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота