В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
chelokoshka03
chelokoshka03
02.08.2020 10:46 •  Информатика

Написать программу, которая запрашивает массив размерности N и выводит на
экран сам массив, а также наибольший и наименьший элементы массива. PascalABC

Показать ответ
Ответ:
protivnuy
protivnuy
23.05.2023 07:40

В непосредственном режиме- видимо без ввода программы, ввести последовательно строки (сначала присваиваем значение переменной икс, затем вычисляем выражение и помещаем это значение в переменную игрек, и после печатаем значение переменной игрек):

LET X=1.12

LET Y=SQR (X^3+EXP X-LN (3*X))*(1+4*SIN (X/2)+5*EXP (SIN X))

PRINT Y

И записать результат вычислений, который высветится на экране (у меня получилось 27.839525 но у вас может немного отличаться).

Надеюсь, что в вашей версии бейсика нет отличий от той, что у меня (она весьма старая).

0,0(0 оценок)
Ответ:
дильназ149
дильназ149
24.01.2021 17:55
1. Вот так сейчас решают подобные задачи:

// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
begin
  Writeln(Range(1,100).Select(i->sin(i)*cos(i)).Where(x->x<>0).Average)
end.

Тестовое решение:
-0.00136006072493969

2. А вот так учат писать это же школьные учителя:

// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
var
  m:array[1..100] of real;
  i,k:integer;
  s:real;

begin
  s:=0;
  k:=0;
  for i:=1 to 100 do begin
    m[i]:=sin(i)*cos(i);
    if m[i]<>0 then begin
      s:=s+m[i];
      k:=k+1
      end
    end;
  Writeln(s/k)
end.

Тестовое решение:
-0.00136006072493969
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота