В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kekmanchik
kekmanchik
15.04.2022 22:18 •  Информатика

Написать программу, которая запрашивает имя файла и распечатывает из него только те строки, которые являются палиндромами(python)

Показать ответ
Ответ:
К1а2т3я456
К1а2т3я456
06.10.2020 13:10
Python 2.7
def main('__init__')
    text=read(file)
    for i in strings(text)
        if i is i.palyndrome()
            print(i)
0,0(0 оценок)
Ответ:
misterkorolev0
misterkorolev0
06.10.2020 13:10
# Python 3.6.1

print("Введите имя файла: ",end='')
f = open(input())
for S in f:
   if S[-1] == '\n':
      S = S[:-1]
   L = len(S)
   B = 1
   for i in range(L//2):
      if S[i] != S[L-i-1]: B = 0
   if B == 1:
      print(S)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота