В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
vladamalaxova
vladamalaxova
16.05.2022 08:24 •  Информатика

Написать программу, которая заменяет все заглавные буквы строчными, а строчные – заглавными в заданной символьной строке. (паскаль)

Показать ответ
Ответ:
Pars1fal
Pars1fal
02.10.2020 14:32
Program X; //работает только для русских строк
var   
    i: longint;   
    s: string;
begin
    readln(s);
    for i := 1 to length(s) do
        if (ord(s[i]) >= 192) and (ord(s[i]) <= 223) then
            s[i] := chr(ord(s[i]) + 32)
        else if (ord(s[i]) >= 224) and (ord(s[i]) <= 255) then
            s[i] := chr(ord(s[i]) - 32);
    writeln(s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота