В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
poster1312
poster1312
13.10.2020 22:17 •  Информатика

Написать программу, которая выводит пример на вычитание (в пределах 100), запрашивает ответ пользователя, проверяет ответ и выводит сообщение "правильно! " или "вы ошиблись" и правильный результат

Показать ответ
Ответ:
DevochkaYmnichka
DevochkaYmnichka
23.05.2020 15:36

program ProgramXY;
const n=100;

var inputText : integer;
begin  Randomize;

var x := Random(n) + 1;

var y := Random(n) + 1;

var z := x - y;

writeln('Решите пример: ', x, ' - ', y, ' = ');

readln(inputText);

if inputText = z then    writeln('Правильно!')

else    writeln('Вы ошиблись! Правильный ответ: ', z)

end.

 

Где-то так это выглядит на Паскале. Ошибки не обработаны, так что, если вместо числа ввести строку - программа умрет по исключению.

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота