Написать программу, которая выводит пример на умножение двух однозначных чисел, которые выбираются случайным образом, запрашивает ответ пользователя, проверяет его и выводит сообщение «правильно! » или «вы ошиблись» и верный результат. pascal abc
Var a,b,r:byte; begin randomize; a:=Random(9)+1; b:=Random(9)+1; Write(a,' x ',b,' = '); Readln(r); if r=a*b then Writeln('Правильно!') else Writeln('Вы ошиблись. Верный результат ',a*b) end.
a,b,r:byte;
begin
randomize;
a:=Random(9)+1;
b:=Random(9)+1;
Write(a,' x ',b,' = ');
Readln(r);
if r=a*b then Writeln('Правильно!')
else Writeln('Вы ошиблись. Верный результат ',a*b)
end.