В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Написать программу, которая выводит на экран из введенной пользователем строки слово с заданным пользователем номером c++ ,

Показать ответ
Ответ:
liza1329
liza1329
05.10.2020 20:48
#include <bits/stdc++.h>
using namespace std;
int main(){    string s; getline(cin, s);    int n; cin >> n;    int cur = 1, i;    for(i = 0 ; i < s.size() ; i ++)    {        if(s[i] == ' ')            cur++;        if(cur >= n)            break;    }    string ans = "";    if(n != 1)        ++i;    while(s[i] != ' ' && i < s.size())    {        ans += s[i];        ++i;    }    cout << ans << "\n";}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота