В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Ppoligoon
Ppoligoon
23.11.2020 13:42 •  Информатика

Написать программу, которая выводит на экран 2, идущих последовательно, члена ряда Фибоначчи, ближайших к целому n. Так чтобы первый из них был меньше, а второй – больше либо равен n. n вводится с клавиатуры. Оно не меньше 2 и не превышает 2 000 000 000.

Показать ответ
Ответ:
Prinsess1
Prinsess1
05.01.2023 08:52

1

Serial.write ()

Записывает двоичные данные в последовательный порт. Эти данные отправляются в виде байта или серии байтов; чтобы отправить символы, представляющие цифры номера, используйте вместо этого функцию print ().

Serial.print ()

Печатает данные на последовательный порт в виде удобочитаемого текста ASCII.

2

Тег <input> является одним из разносторонних элементов формы и позволяет создавать разные элементы интерфейса и обеспечить взаимодействие с пользователем.

Инструкция read предназначена для ввода с клавиатуры значений переменных (исходных данных). ... Программа приостанавливает свою работу и ждет, пока на клавиатуре будут набраны нужные данные и нажата клавиша <Enter>.

3

Системный вызов close - это системный вызов, используемый ядром для закрытия файлового дескриптора.  Для большинства файловых систем программа завершает доступ к файлу в файловой системе, используя системный вызов close.  Это очищает файловые буферы, обновляет метаданные файлов, которые могут включать в себя индикатор конца файла в данных;  освобождает ресурсы, связанные с файлом (включая дескриптор файла), и обновляет общесистемную таблицу используемых файлов.  Некоторые языки программирования поддерживают структуру данных файлов, открываемых их библиотекой времени выполнения, и могут закрыться при завершении программы.  Эта практика известна как инициализация получения ресурсов (RAII).  Некоторые операционные системы будут вызывать закрытие файлов, хранящихся в программе, если она завершается.  Некоторые операционные системы вызывают системный вызов close как часть восстановления операционной системы в результате сбоя системы

0,0(0 оценок)
Ответ:
yulyaartemowa20
yulyaartemowa20
10.03.2021 07:34
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#include <conio.h>

int main() {
   double a, b, y;
   int x;

   a = 6.72f;
   b = 4.85f;
   printf("vvedite x=");
   scanf("%d", &x);

   switch (x) {
       case 1: y = 1 + sqrt(a + abs(x)); break;
       case 7: y = 2 + a*a*x*x + exp(x); break;
       case 5: y = x*sqrt(1+b*log(a*a*x)); break;
       default:
          printf("znachenie x zadano neverno\n");
          printf("nagmi Enter\n");
          getch();
          return 0;
   }

   printf("x=%2dy=%5.2lf", x, y);
   getch();
   return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота