В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Написать программу, которая выводила на экран числа от 1 до 50 в строчку я реально не догоняю
В формате
CLS
FOR
PRINT
NEXT
Буду очень благодарна

Показать ответ
Ответ:
Julia10988
Julia10988
30.03.2021 02:30

Обращая внимание на существующий порядок в природе, мы часто в качестве примера указываем на кристаллы, в кристаллической решетке которых строго чередуются ионы вещества (например, Na+ и Сl– в поваренной соли). Строго упорядоченную структуру имеют и кристаллические металлы. В узлах кристаллической решетки меди располагаются положительно заряженные ионы.

Однако наряду с существующим порядком в природе часто соседствует и беспорядок (хаос). В тех же кристаллах металлов, наряду с упорядоченной ионной решеткой, имеются свободные электроны, которые беспорядочно и хаотично движутся.

Порядок и беспорядок наблюдаются, например, и в космосе. С одной стороны, мы знаем, что планеты движутся по определенным орбитам со строго определенной скоростью. А с другой стороны, в космосе, помимо планет, имеется межзвездное вещество, которое хаотически движется в пространстве, и там, где образуются большие скопления этого вещества, возникают значительные гравитационные силы, в результате чего могут образоваться звездные системы с высокой степенью упорядоченности.

Последний пример указывает на существование процессов и механизмов, ведущих от беспорядка к порядку. Эта особенность подмечена еще в древнегреческой мифологии, где под хаосом понималась «беспредельная, первобытная материя», из которой образовалось все существующее.

Можно привести еще больше примеров перехода от порядка, упорядоченности к хаосу. Так, если нагревать кристаллы поваренной соли, то амплитуда колебаний атомов увеличивается, связь между атомами уменьшается, упорядоченная структура кристалла разрушается и исчезает, а атомы начинают хаотически двигаться. Приведенный пример иллюстрирует процессы, связанные с действием одного из фундаментальных законов природы, имеющего универсальный характер, а именно: со вторым началом (законом) термодинамики.

0,0(0 оценок)
Ответ:
8479
8479
14.07.2021 22:22

Язык Паскаль.

Program Ski;

const n=5; {длина массива}

var: a:array [1..n] of integer; i,s:integer;

begin

For i:=1 to n do begin

                          Writeln('vvedite element massiva nomer ',i);

                          Read(a[i]);

                        end;    {Тут мы просим пользователя ввести элементы}

s:=0; {s - это указанная тобой сумма. Мы ее соответственно обнуляем сначала}

for i:=1 to n do begin

                          if a[i] mod 10=0 then s:=s+a[i];  

                       end;    

 

{ берем каждый элемент массива, и проверяем, делится ли он на 10 без остатка(mod- это остаток от деления на указанное число). Если все в порядке, тогда прибавляем число к общей сумме }

 

Writeln('summa elementov ravnih nulu ',s);  {пишет ответ}

readln; {чтобы сразу не закрывалась программа}

end.

 

Если возникнут вопросы или появится еще подобное задание для решения, пиши прямо в личку. Мне все равно делать нечего )

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота