В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Mishanaxsar
Mishanaxsar
18.12.2020 03:47 •  Информатика

Написать программу, которая выполняет следующую задачу (без использования string): Оставить в предложениях слова, отличающиеся от последнего слова предложения, в которых первая буква слова входит в него еще только один раз.

Показать ответ
Ответ:
doagetonya
doagetonya
26.09.2021 06:31
1 вариант (с использованием типа real)

program raf105;

var a:array[1..8] of real;

i,n:integer;

x:real;

begin

write('Введите номер билета: ');

readln(x);

n:=8;

for i:=1 to 8 do

begin

 n -= 1;

 if i=1 then

   a[i]:= trunc(x / (10**7))

 else if i=8 then

   a[i]:= round(frac(x / 10)*10)

 else

 a[i]:= round(frac((trunc(x / (10**n))) / 10)*10);

end;

if a[1]+a[2]+a[3]+a[4]=a[5]+a[6]+a[7]+a[8]

 then writeln('Номер билета является счастливым')

 else writeln('Номер билета не является счастливым');

end.

2 вариант (с использованием типа string)

program raf105;

var a:array[1..8] of integer;

i:integer;

x:string;

begin

write('Введите номер билета: ');

readln(x);

for i:=1 to 8 do

 a[i]:= ord(x[i])-48;

if a[1]+a[2]+a[3]+a[4]=a[5]+a[6]+a[7]+a[8]

 then writeln('Номер билета является счастливым')

 else writeln('Номер билета не является счастливым');

end.

Язык PascalABC

0,0(0 оценок)
Ответ:
алина3893
алина3893
11.11.2021 20:52

$ & % { \  

Объяснение:

Следующие символы являются   зарезервированными символами, которые либо имеют в LATEX специальное значение, либо имеются не во всех шрифтах. Если вы введете их в текст напрямую, то они обычно не напечатаются, а заставят LATEX сделать что-нибудь, вами вовсе не предусмотренное.  

$ & % # _ { } ~ ^ \  

Как вы позже увидите, эти символы можно использовать в ваших документах, добавляя к ним префикс <<\>>:  

\$ \& \% \# \_ \{ \}

$ & % # _ { }  

Прочие символы, как и многие, многие другие, можно набрать специальными командами в математических формулах или как акценты. Знак <<\>> нельзя вводить, добавляя перед ним еще один, так как эта команда (\\) используется для разрыва строки3.

Источник: http://tex.imm.uran.ru/tex/2e/lshort2e/node11.html

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота