В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Darina6940
Darina6940
16.07.2022 09:52 •  Информатика

Написать программу, которая вычисляет среднее арифметическое ненулевых элементов введенного с клавиатуры массива целых чисел. ниже рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом). введите элементы массива (10 целых чисел) в одной строке и нажмите . -> 23 0 45 -5 12 0 -2 30 0 64 сумма элементов массива: 184 кол-во ненулевых элементов: 7 среднее арифметическое ненулевых элементов: 23.86

Показать ответ
Ответ:
dashanovikova03
dashanovikova03
28.05.2020 19:02

var mas:array[1..10] of integer;

   i,kolvo:integer;

   b:real;

   

begin

writeln('Введите 10 целых чисел: ');

for i:=1 to 10 do

begin

read(mas[i]);

kolvo:= kolvo+1;

if (mas[i]=0) then kolvo:= kolvo-1;

end;

 

for i:=1 to 10 do  

begin

b:=mas[i] + b;

end;

 

b:= b/kolvo;

 

writeln('Количество ненулевых чисел= ', kolvo);

writeln('Среднее арифметическое ненулевых чисел= ', b);

 

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота