В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
yana603
yana603
05.02.2021 22:08 •  Информатика

Написать программу которая вычисляет оптимальный вес пользователя сравнивая его с реальными выдаёт рекомендации о необходимости поправиться или похудеть.по формуле рост минус написать то легко но учитель
сказал что б говорилось на сколько худеть или поправиться надо ну ни как не могу додуматься(( (( вот сама написаная программа program zadacha1; var ves, rost, optves: integer; begin write('введите массу тела'); read(ves); write('введите рост в см');
read(rost); optves: =rost-100; if ves> optves then write('вам необходимо похудеть' ); if ves

Показать ответ
Ответ:
Sashaklapp
Sashaklapp
24.05.2020 04:19

Program Zadacha1;
Var ves, rost, optVes:integer;
Begin
  write('введите массу тела');
  read(ves);
  write('введите рост в см');
  read(rost);
  optVes:=rost-100;
  if ves>optVes then write('вам необходимо похудеть на', abs(optVes-ves) );
  if ves<optVes then write('вам необходимо поправиться на', abs(optVes-ves) );
  if ves=optVes then write ('ваш вес оптимальный')
End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота