В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
saqo2017
saqo2017
14.03.2020 12:42 •  Информатика

Написать программу, которая вычисляет факториал введенного с клавиатуры числа. (Факториалом числа п называется произведение целых чисел от 1 до n. Например, факториал 1 равен 1, 8-40320). Должен считать до 100. Вычисление факториала. Введите число, факториал которого надо вычислить › 7 Факториал 7 равен 504 0

Показать ответ
Ответ:
bulyginaap08na1
bulyginaap08na1
15.10.2020 14:40

Сам код(Для C++):

#include <iostream>  

using namespace std;  

long double fact(int N)  

{

if(N < 0) // если пользователь ввел отрицательное число

return 0; // возвращаем ноль

if (N == 0) // если пользователь ввел ноль,

return 1; // возвращаем факториал от нуля

else // Во всех остальных случаях

return N * fact(N - 1); // делаем рекурсию.  

}

int main()  

{

int N; setlocale(0,""); // Включаем кириллицу  

cout << "Введите число для вычисления факториала: ";

cin >> N;

cout << "Факториал для числа " << N << " = " << fact(N) << endl << endl; // fact(N) - функция для вычисления факториала.

return 0;  

}

Объяснение:

2.1. Формулировка задания.

Разработка программы для вычисления факториала.

Факториал числа — это произведение натуральных чисел от 1 до самого числа (включая данное число). Обозначается факториал восклицательным знаком «!».  

Например,

5!=1×2×3×4×5

3!=1×2×3

И тому подобное.

Создаем новый текстовый документ, вводим код для вычисления факториала. После этого компилируем программу.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота