В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
lucky20171
lucky20171
02.02.2023 02:55 •  Информатика

Написать программу, которая - вводит в компьютер с клавиатуры годовые оценки к учеников класса; - подсчитывает и выводит на экран среднюю оценку в классе; - подсчитывает и выводит на экран количество учеников, у которых оценка выше средней.

Показать ответ
Ответ:
ulanachukalkina
ulanachukalkina
05.10.2020 05:24
// PascalABC.NET 3.2, сборка 1377 от 19.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var k:=ReadInteger('k=');
  var a:=ReadArrInteger('Вводите оценки:',k);
  var m:=a.Average;
  Writeln('Средняя оценка по классу: ',m:4:2);
  Writeln('Учеников с оценкой выше средней: ',a.Where(x->x>m).Count)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота