В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
aliana77777
aliana77777
09.06.2023 12:30 •  Информатика

Написать программу, которая вводит с клавиатуры координаты центра и радиус окружности, рисует окружность с заданными параметрами и перемещает его по центру экрана снизу вверх. Окружность закрасить желтым цветом, а фон - синим.
Программа нужна в C++ (Желательно с комментариями ! Заранее !

Показать ответ
Ответ:
schoolboy371
schoolboy371
30.05.2021 20:14

Объяснение:

Приведите примеры ситуаций, в которых информация:

собирается - опрос журналистом людей для статьи в газете

обрабатывается - решение учеником задачи

упрощается - тбъяснение учителем материала урока

создается - придумывание журналистом статьи (как ее написать, что в ней написать и т.д)

запоминается - выучивание учеником стиха

измеряется - рассчитывание программистом объема, который займет написанная им программа

копируется - списывание учеником домашнего задания у одноклассника

передается - распространение слухов внутри класса или школы (один рассказал, другой передал и так далее)

принимается - ученики слушают, что им рассказывает учитель на уроке

разрушается - отклонение написанной статьи журналиста

делится на части - работа с текстом на уроке русского языка (вставить запятые, буквы, например)

ищется - поиск материала для написания сообщения, доклада на какой-либо урок

Надеюсь, смогла

0,0(0 оценок)
Ответ:
daniltyrov719
daniltyrov719
15.02.2023 13:58
//Вот программа, которая кодирует слова в системах счисления от 2 до 10
//Первый ввод - число, второй - система счисления
//Pascal ABC.NET v3.0

var
 a,i,b,r,n,j,bug:integer;
 s,se,slo,slof:string;

procedure preob(var a,b,n:integer; var se:string);
 begin
  repeat
   b:=a mod n;
   a:=a div n;
   str(b,se);
   s+=se;
  until (a<=n-1);
 end;

begin
readln(slo);
readln(n);
for j:=1 to length(slo) do
begin;
a:=ord(slo[j]);
preob(a,b,n,se);
str(a,se);
s+=se;
for i:=1 to length(s) div 2 do
begin;
se:=s[i];
s[i]:=s[length(s)-i+1];
s[length(s)-i+1]:=se[1];
end;
write(s,'-');
slof:=slof+s;
delete(s,1,length(s));
end;
end.

//Слово Программа она кодирует как 11001111-11110000-11101110-11100011-11110000-11100000-11101100-11101100-11100000-
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота