Написать программу, которая вводит с клавиатуры данные, содержащие информацию: табельный номер работника, ФИО работника, год рождения, пол, код отдела и создает массив структур. По введенному с клавиатуры коду подсчитать средний возраст работников этого отдела. Программа нужна в C++ (желательно с комментариями ! Заранее .
1 Центральная часть компьютера, выполняющая заданные программой преобразования информации и осуществляющая управление всем вычислительным процессом.
2 Процессоры конструктивно могут выполняться как в виде одной большой интегральной микросхемы — чипа, так и в виде нескольких микросхем, блоков электронных плат устройств.
3 Управля́ющий автома́т, устро́йство управле́ния проце́ссором — блок, устройство, компонент аппаратного обеспечения компьютеров.
4 Арифме́тико-логи́ческое устро́йство — блок процессора, который под управлением устройства управления служит для выполнения арифметических и логических преобразований над данными
5 технологический процесс изготовления полупроводниковых изделий и материалов; состоит из последовательности технологических и контрольных операций
а на шестой ответа не знаю(
Объяснение:
const
n=5;
var
a:array[1..n,1..n] of integer;
x:array[1..n] of double;
i,j,k:byte;
begin
Randomize;
Writeln('*** Исходный массив ***');
for i:=1 to n do begin
for j:=1 to n do begin
a[i,j]:=Random(51)-25;
Write(a[i,j]:4)
end;
Writeln
end;
Writeln('*** Массив x ***');
for j:=1 to n do begin
x[j]:=0; k:=0;
for i:=1 to n do
if a[i,j] mod 2=0 then begin
x[j]:=x[j]+a[i,j]; Inc(k)
end;
if k>0 then x[j]:=x[j]/k;
Write(x[j]:0:5,' ')
end;
Writeln
end.
Тестовое решение:
*** Исходный массив ***
-10 18 -8 -15 5
-21 -18 6 -2 9
-7 22 -4 3 14
21 16 -10 -18 -9
17 3 -14 -18 12
*** Массив x ***
-10.00000 9.50000 -6.00000 -12.66667 13.00000