В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
BcezHaNKa
BcezHaNKa
14.02.2022 06:04 •  Информатика

Написать программу , которая вводит с клавиатуры число от 0 до 999999(использовать переменные типа longint) и выдает на экран дисплея сумму цифр этого числа. напишите в делфи .

Показать ответ
Ответ:
rahimzhan20p0dqkg
rahimzhan20p0dqkg
28.09.2020 10:56
Var
    n: longint;
    i, sum: integer;

begin
    Readln(n);
    Sum := 0;
    
    while n > 0 do
    begin
        Sum := sum + (n mod 10);
        n := n div 10;
    end;
    Writeln(sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота