В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
odinokijcelovek
odinokijcelovek
03.07.2021 20:56 •  Информатика

Написать программу, которая вводит двумерный массив 3х3, выводит его на экран в виде матрицы, а затем выводит количество отрицательных элементов. Я программу написала, но не понимаю, где ошибка
program mas2;
const
m=3;
n=3;
var
i, j, c: Integer;
a: array [1..m, 1..n] of Integer;
begin
for i := 1 to m do
for j := 1 to n do
read (a[i,j]);
for i := 1 to m do
begin
for j := 1 to n do
write (a[i,j]:6);
writeln;
c := 0;
if a[i, j] < 0 then
c:=c+1;
end;
WriteLn('Количество отрицательных элементов равно ', c);
end.

Показать ответ
Ответ:
лпрпаи
лпрпаи
23.08.2020 19:51

Вы забыли поместить команды цикла в блок "begin-end", а также зачем-то внутри цикла каждый раз обнуляли переменную c. Взгляните на исправленный вариант:

program mas2;

const

m=3;

n=3;

var

i, j, c: Integer;

a: array [1..m, 1..n] of Integer;

begin

for i := 1 to m do

for j := 1 to n do

read (a[i,j]);

c := 0;

for i := 1 to m do

begin

for j := 1 to n do

begin  

write (a[i,j]:6);

if a[i, j] < 0 then

c:=c+1;

end;

writeln;

end;

WriteLn('Количество отрицательных элементов равно ', c);

end.


Написать программу, которая вводит двумерный массив 3х3, выводит его на экран в виде матрицы, а зате
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота