В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Polina8Let
Polina8Let
23.01.2020 02:26 •  Информатика

Написать программу, которая водит натуральные числа от a до b и выводит все простые числа в диапазоне от a до b. на python !

Показать ответ
Ответ:
konoki1982
konoki1982
12.02.2023 14:05

var x,y : Array of integer;

j,i,o,e,n1,n2 :integer;

begin

 writeln('Первый массив');

 writeln('Сколько нулей?');

 readln(o);

 writeln('Сколько единиц?');

 readln(e);

 writeln('С какого числа начинаются единицы по размеру массива?');

 readln(n1);

 writeln('С какого числа начинаются нули по размеру массива?');

 readln(n2);

 if (n1 > n2) and (e > o) then

   begin

   setlength(x,(n1+e));

   end

 else

   begin

   setlength(x,(n2+o))

   end;

 for i:= 0 to 10 do

    begin

    Write('-':2);

 end;

 writeln();

 writeln('Заполнение первого массива');

 for i:= 0 to 10 do

    begin

      Write('-':2);

    end;

 Writeln();

   if (n1 > n2) and (e > o) then

   begin

     for i:= 0 to (n1+e) do

       begin

         if e = 0 then

          begin

          end

        else

          begin

            x[i] :=0;

          end;

         for j := n1 to (n1+e) do

           begin

           x[j] := 1;

           end;

       end;

   end

 else

   begin

     for i:= 0 to (n2+o) do

       begin

         if o = 0 then

          begin

          end

        else

          begin

            x[i] :=0;

          end;

        for j := n1 to (n1+e) do

         begin

         x[j] := 1;

         end;

       end;

   end;

   if (n1 > n2) and (e > o) then

   begin

     for i:= 0 to (n1+e) do

       begin

         Write(x[i],' ');

       end;

   end

 else

   begin

     for i:= 0 to (n2+o) do

       begin

        Write(x[i],' ');

       end;

   end;

 writeln();

 writeln('Второй массив');

 writeln('Сколько нулей?');

 readln(o);

 writeln('Сколько единиц?');

 readln(e);

 writeln('С какого числа начинаются единицы по размеру массива?');

 readln(n1);

 writeln('С какого числа начинаются нули по размеру массива?');

 readln(n2);

 if (n1 > n2) and (e > o) then

   begin

   setlength(y,(n1+e));

   end

 else

   begin

   setlength(y,(n2+o))

   end;

 for i:= 0 to 10 do

    begin

    Write('-':2);

 end;

 writeln();

 writeln('Заполнение второго массива');

 for i:= 0 to 10 do

    begin

      Write('-':2);

    end;

 Writeln();

   if (n1 > n2) and (e > o) then

   begin

     for i:= 0 to (n1+e) do

       begin

        if e = 0 then

          begin

          end

        else

          begin

          y[i] :=0;

          end;

         for j := n1 to (n1+e) do

           begin

           y[j] := 1;

           end;

       end;

   end

 else

   begin

     for i:= 0 to (n2+o) do

       begin

        if o = 0 then

          begin

          end

        else

          begin

          y[i] :=0;

          end;

        for j := n1 to (n1+e) do

         begin

         y[j] := 1;

         end;

       end;

   end;

   if (n1 > n2) and (e > o) then

   begin

     for i:= 0 to (n1+e) do

       begin

         Write(y[i],' ');

       end;

   end

 else

   begin

     for i:= 0 to (n2+o) do

       begin

        Write(y[i],' ');

       end;

   end;

 

 

end.


Какие ситуации смог представил то и смог сделать. Тестером побудешь ты.

0,0(0 оценок)
Ответ:
tema152331
tema152331
20.02.2021 15:56

Плюсы:

-Возможность доступа к данным с любого компьютера, имеющего выход в Интернет.

-Высокая вероятность сохранения данных даже в случае аппаратных сбоев.

Минусы:

-Провайдер имеет возможность просматривать данные клиента (если они не защищены паролем), которые также могут попасть в руки хакеров, сумевших взломать системы защиты провайдера.

-Общая производительность при работе с данными в «облаке» может быть ниже, чем при работе с локальными копиями данных.

Привел по два плюса и минуса, на всякий случай.  

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота