В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
whale66666
whale66666
05.03.2022 12:22 •  Информатика

Написать программу, которая в заданном одномерном массиве размерности n меняет местами соседние элементы, стоящие на чётных местах, с соседними элементами, стоящими на нечётных местах.

Показать ответ
Ответ:
ksenia32
ksenia32
16.06.2020 11:19

var a:array[1..10] of integer;
i,tmp:integer;

begin  cls;
 for i:=1 to 10 do a[i]:=i;
 
 for i:=1 to 10 do
 begin
 if i mod 2 = 1 then
 begin
 tmp:=a[i];
 a[i]:=a[i+1];
 a[i+1]:=tmp;
 end;
 
 end;
for i:=1 to 10 do
write(a[i], ' ');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота