Написать программу, которая в последовательности вводимых с клавиатуры символов определяет, сколько было введено символов английского языка, сколько было введено символов русского языка, сколько цифр, сколько остальных знаков. Признаком конца последовательности считать символ точки '.'
Программу нужно написать на Паскале.
2) в 1 дюйме = 2,54 см, значит в 10 см содержится 3,94 дюйма (10/2,54 = 3,94)
3) 3,94* 1200 = 4728 пикселей по ширине и по высоте экрана
4) 4728 * 4728 = 22353984 точек в цветном изображении 10 на 10 см
5) 22353984 * 24 = 536495616 бит - информационный объем изображения
Переведем в большие единицы измерения:
536495616 бит / 8 = 67061952 байт / 1024 = 65490,2 Кбайт / 1024 = 64 Мбайта
ответ: полученный файл будет 64 Мбайта.
#include <iostream>
inline void sort(int *a, int *b, int *c);
int main()
{
int x, y, z;
std::cin >> x >> y >> z;
void (*ptr)(int *x, int *y, int *z);
ptr = sort;
(*ptr)(&x, &y, &z);
std::cout << x << " " << y << " " << z << std::endl;
system("pause");
return 0;
}
inline void sort(int *a, int *b, int *c)
{
if (*b < *a) std::swap(*a, *b);
if (*c < *a) std::swap(*a, *c);
if (*c < *b) std::swap(*b, *c);
}