В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
MrEdgik
MrEdgik
06.04.2021 10:37 •  Информатика

Написать программу, которая суммирует 12 любых чисел (вводит пользователь или генератор случайных чисел). Использовать цикл for. Переменных не более 5 шт. и использовать цикл While. PascalABC. ​

Показать ответ
Ответ:
Sonyamay
Sonyamay
09.08.2020 22:38

1) Цикл for

uses crt;

var j,count,i:integer;

begin

j:=0;

for i:=1 to 12 do

begin

 readln(count);

 j:=j+count;

end;

writeln(j);

end.

2) Цикл While

uses crt;

var j,count,i:integer;

begin

j:=0;

i:=0;

while i < 12 do

begin

 readln(count);

 j:=j+count;

 i:=i+1;

end;

writeln(j);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота