В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
якек2
якек2
23.05.2022 06:20 •  Информатика

Написать программу, которая сравнивает два целых числа и выводит на экран наибольшее.

Показать ответ
Ответ:
Linka00128
Linka00128
19.06.2022 09:54

Приведу в пример A и B, они могут принимать два значения истинна и не истинна, тоесть + или -

И

Если A истинно и B истинно, то выражение истинно

если A или B не истинно, то выражение не истинно

ИЛИ

Если или A или B истинно, то выражение истинно

Может быть такое что и A и B истинны, в этом случае выражение тоже истинно

>, <, >=, <=, =

> - больше

< - меньше

>= - больше либо равно

< - меньше либо равно

= - равно

если к примеру A = 10, а B = 20.

A > B? Нет. Выражение не истинно.

A < B? Да. Выражение истинно.

A >= B? Нет. Выражение не истинно.

A <= B? Да. Выражение истинно.

A = B? Нет. Выражение не истинно.

0,0(0 оценок)
Ответ:
riaskor
riaskor
27.12.2022 09:56

<code>

#include <iostream>

using namespace std;

int main()

{

   int n,m;

   cout<<"Размер матрицы:\n";

   cout<<"n:";cin>>n;

   cout<<"m:";cin>>m;

   int **matrix = new int*;

   for(int i = 0;i<n;i++){

       matrix[i] = new int;

   }

   for(int i = 0;i<n;i++){

       for(int j = 0;j<m;j++){

           cin>>matrix[i][j];

       }

   }

   for(int i = 0;i<n;i++){

       for(int j = 0;j<m;j++){

           if(matrix[i][j]<0){

               cout<<"Первый отрицательный элемент в строке "<<i<<" - "<<matrix[i][j]<<endl;

               break;

           }

           else if(j == m-1 && !(matrix[i][j]<0)){

               cout<<"В строке "<<i<<" нет отрицательных чисел"<<endl;

           }

       }

   }

   return 0;

}

</code>

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота