Написать программу, которая спрашивает у пользователя число, после этого выводит строку типа: 2 компьютера. В зависимости от введенного числа, программа должна корректно подставлять окончание для слово компьютер Пример:
Ввод: Пользователь ввел число 12
Вывод: 12 компьютеров
(Код должен работать с любым числом)
n = int(input("введи число"))
if n%10== 1:
print(n,"компьютер")
elif (n%10==2 or n%10==3 or n%10==4):
print(n,"компьютера")
else:
print(n,"компьютеров")
Объяснение:
язык программирования (С++)
int main() {int a;cin>> a; if (a<4) {cout << a " компьютерa " ;}else {cout<< a"компьютеров"} return 0;}