В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
natalia1676
natalia1676
26.12.2022 15:51 •  Информатика

Написать программу, которая сможет определить, есть ли среди цифр заданного целого трёхзначного числа одинаковые. даны три переменные вещественного типа: a, b, c. если их значения по возрастанию или убыванию, то удвоить их; в противном случае заменить значение каждой переменной на противоположное. вывести новые значения переменных a, b, c.

Показать ответ
Ответ:
kristail2003101979
kristail2003101979
10.06.2020 22:20

1. 

var
n, a, b, c: integer;

begin
readln(n);
a := n div 100;
b := n div 10 mod 10;
c := n mod 10;
if (a = b) or (b = c) or (a = c) then writeln('YES')
else writeln('NO');
end.

 

2.

var
a, b, c: real;

begin
readln(a, b, c);
if ((a < b) and (b < c)) or ((a > b) and (b > c)) then begin a := a * 2;b := b * 2;c := c * 2; end
else begin a := -a;b := -b;c := -c; end;
writeln(a,' ', b,' ', c);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота