В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
alexstew1
alexstew1
15.10.2021 21:35 •  Информатика

Написать программу,которая считает длину строки,введенной с клавиатуры и вывести её без третьего символа.

Показать ответ
Ответ:
olya355
olya355
03.10.2020 03:10
Var        str: string;        i, count: integer;begin        write('Your string: ');        readln(str);        i := length(str);        if i > 0 then begin                count := 1;                while i > 0 do begin                        if str[i] = ' ' then                                count := count + 1;                        i := i - 1;                end;        end        else                count := 0;                delete(str,3,1);        writeln('Number of words: ', count);         writeln(str);readln;end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота