В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Evelinahomytova
Evelinahomytova
14.09.2021 23:44 •  Информатика

Написать программу которая решает уравнение ax^2+bx+c=0 . если d< 0 то решений нет , если d=0 то 1 корень. еси d > 0 - 2 корня

Показать ответ
Ответ:
Nikitaue
Nikitaue
07.10.2020 20:51
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
var (a,b,c):=ReadReal3('введите a, b и c через пробел');
var D:=b*b-4*a*c;
if D>0 then write('два различных корня: x1=',(-b+sqrt(D))/(2*a),'; x2=',(-b-sqrt(D))/(2*a)) else if D=0 then
write('два совпадающих корня: x1=x2=',-b/(2*a)) else
write('нет действительных корней');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота