Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
Kvintsekstakkord
29.09.2022 22:39 •
Информатика
Написать программу которая проверяет -является ли сумма цифр заданного трехзначного числа четным числом
Показать ответ
Ответ:
Nasta11111112356
21.08.2020 12:26
C++
size_t sum(size_t val)
{
static size_t temp = 0;
if (val > 0) {
sum(val / 10);
temp += val % 10;
}
return temp;
}
int main()
{
(sum(123) % 2) == 0 ? cout << "True" : cout << "False";
}
0,0
(0 оценок)
Популярные вопросы: Информатика
katasinicina39
09.05.2020 00:50
Запишем программу по сохранению файла с использованием условных операторов и операторов сравнения...
Zepstro
18.04.2020 17:18
Задание 5. Допишите пропущенные слова. Процессор предназначен и работой компьютера. ...
АльфисГугу
31.05.2023 11:26
Изучите блок-схему и напишите словесно-формульный алгоритм (псевдокод)...
hdbhbd
30.08.2022 22:28
Представьте ip адрес компьютера в 32 битном коде 175.141.31.211...
polinaguskova
29.01.2021 03:21
Задание 1. Создать проект который позволяет определить сопротивление алюминиевого провода, имеющего длинуІи площадь поперечного сечения S1Используя выражение R=pгде р=0,028SОГІнщите...
InnaGlazova
28.11.2021 14:28
Домашнее задание. Создайте программу для расчёта времени движения автомобиль от пункта А до пункта Б. условия задачи. средняя скорость движения легкового автомобиля по трассе...
fragerin
13.02.2022 16:49
Напиши программу по блок-схеме...
csmurzik
09.02.2022 11:15
Напишите программу, которая вычисляет среднюю за неделю температуру воздуха. Исходные данные вводятся с клавиатуры....
xeniaverner
31.07.2021 01:42
7. Какой режим обновления оглавления нужно выбрать, если в текстовый документ после создания оглавления добавляются изображения, таблицы илитекстовая информация?Обновление...
Sudzuky
25.02.2020 08:00
Нарисовать бассейн и сделать скрины по пунктам: один)Основная окружность, сделать из нее цилиндр используя инструмент«Тяни/толкай» - б)Внутренняя окружность, используя инструмент...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
size_t sum(size_t val)
{
static size_t temp = 0;
if (val > 0) {
sum(val / 10);
temp += val % 10;
}
return temp;
}
int main()
{
(sum(123) % 2) == 0 ? cout << "True" : cout << "False";
}