В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Vova77723
Vova77723
21.10.2022 12:15 •  Информатика

Написать программу, которая проверяет является ли строка, введенная с клавиатуры палиндромом (пробелы игнорировать). pascal abc

Показать ответ
Ответ:
Demel
Demel
27.08.2020 07:50
Var
  s:string;
  i,n:byte;
  p:boolean;
begin
  Write('Введите строку: ');
  Readln(s);
  n:=Length(s);
  for i:=n downto 1 do
    if s[i]=' ' then Delete(s,i,1);
  n:=Length(s);
  p:=true;
  for i:=1 to n div 2 do
    if s[i]<>s[n-i+1] then
    begin
      p:=false;
      break
    end;
  if p then Writeln('Палиндром')
  else Writeln('Не палиндром')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота