В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Ошлиарлт
Ошлиарлт
25.01.2023 21:12 •  Информатика

Написать программу, которая проверяет следующий факт: все цифры данного четырехзначного числа n различны

Показать ответ
Ответ:
sqerrr
sqerrr
09.10.2020 15:42

var n,a,b,c,d:integer;

begin

readln(n);

a:=n mod 10;

b:=(n div 10) mod 10;

c:=(n div 100) mod 10;

d:=n div 1000;

if((a-b<>0)or(c-d<>0)or(a-d<>0)) then writeln('Цифры введённого четырёхзначного числа различны') else

writeln('Цифры введённого четырёхзначного числа одинаковы');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота