В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
fainakorolenko
fainakorolenko
21.09.2022 06:22 •  Информатика

Написать программу которая про суммирует все 2ух значные числа содержащие 1

Показать ответ
Ответ:
nikitabelokon21
nikitabelokon21
12.06.2020 06:55

var a,a1,a2,sum,n,i:integer;

begin

readln (n);

for i:=1 to n do

begin

readln (a);

a1:=a div 10;

a2:=a mod 10;

if (a1=1) or (a2=1) then sum:=sum+a;

end;

writeln (sum);

end.

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота