В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
feitlol
feitlol
30.05.2022 03:40 •  Информатика

Написать программу, которая позволяет вычислить сумму цифр двузначного числа при условии, что первая цифра больше второй. Например, вводим - 51 программа выводит - 6; вводим - 14 программа выводит - не подходит. Используем для решения div и mod и составной оператор.

Показать ответ
Ответ:
SASHA123741852
SASHA123741852
17.11.2021 13:41

#include <bits/stdc++.h>

using namespace std;

int search1(string str) {

 for (int i = 0; i < str.size(); i++) {

   if (str[i] == 'f') return i;

 }

 return -1;

}

int search2(string str) {

 for (int i = str.size() - 1; i >= 0; i--) {

   if (str[i] == 'f') return i;

 }

 return -1;

}

int main() {

 string str = {};

 getline(cin, str);

 int a = search1(str);

 int b = search2(str);

 if (a != -1) {

   if (a == b)

     cout << a;

   else

     cout << a << " " << b;

 }

 return 0;

}

0,0(0 оценок)
Ответ:
Скажи2018
Скажи2018
26.07.2021 09:45

program D1;

uses GraphABC;

const c: array[1..3] of integer = (15,20,65);

n: array[1..3] of string = (' Белки ',' Жиры ',' Углеводы ');

var nu,u, i: integer;

begin

SetWindowTitle ('Сбалансированное питание');

SetFontSize(15);

TextOut(185,30,'Сбалансированное питание');

SetFontSize(10);

nu:=0;

for i:=1 to 3 do

begin

case i of

1: SetBrushColor(clred);

2: SetBrushColor(clgreen);

3: SetBrushColor(clblue)

end;

TextOut(285,385+(i*20),n[i]+IntToStr(c[i])+' % ');

u:=nu+trunc(c[i]*360/100);

Pie(320,230,150,nu,u);

nu:=u;

end;

SaveWindow ('Диаграмма питания.bmp')

end.

Объяснение:

картинка

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота